Some systems are experiencing issues.
We are experiencing issues on the DNS queries to our nameservers, we're investigating the cause of the issue.
update 09:36
We received a notification our DNS3 server is experiencing high amounts of traffic and we're monitoring this nameserver.
update 10:15
We've increased the resources of the DNS3 server to be able to handle the higher load it is experiencing.
update 11:45
Increasing the resources has now stabilized the load on the DNS3 server, the TCP is still responding slowly, we're continuing our investigation.
update 15:00
DNS3 is now able to handle more connections and queries, there's still a high traffic going to the DNS servers without noticing significant impact.
Incident UUID 7fb413d7-397f-4b9e-8680-bdc192d73182