Some systems are experiencing issues.

1 week ago —
Fixed

Fixed

6 days ago —

All issues have been resolved and services are running normally again. If you still experience any problems, please contact us via https://level27.be/nl/contact. Thank you for your patience.

Watching

1 week ago —

The remaining mail issues have been traced back to a component that did not recover correctly after the earlier network disruption. This has been resolved and mail services are working normally again. We are keeping the incident under monitoring to make sure everything remains stable.

Investigating

1 week ago —

Most services have recovered following the network disruption. Some customers are still experiencing mail issues. We are investigating and will post an update as soon as we know more.

Watching

1 week ago —

A failing cable between our datacenters caused significant packet loss and connectivity issues for a number of customers. We have identified the faulty cable and disabled the affected port, which forced traffic onto the healthy path. Services are recovering and we are seeing connectivity return to normal.

We are actively monitoring the situation and will confirm once everything is fully stable.

1 week ago —

We have noticed a network issue. Our engineers are working on a solution.

Incident UUID ab8dc1d1-caec-4395-9ebb-846bd00c81db